place holders not working in translated Receipt Email Subject

fileeefileee Member
in Bugs & Feature Requests edited February 2016
It appears that the place holders for the email subject are not working in the custom translated fields for other languages

e.g.
"DE": {
'custom_subject': '{{ store_name }} Bestellbestätigung {{ order_id }}',
.......
will result in this nice email subject inside outlook: "{{ store_name }} Bestellbestätigung {{ order_id }}" (yap utf8 is also not working!)

As you can see the whole translation stuff works, its just not replacing the subject place holders. I think you can fix that just by changing some code.

store version: 2.0 latest
store:fileee
Comments
  • fc_adamfc_adam FoxyCart Team
    @fileee,

    The multi-language code is already Twig code - so the values within that array won't be processed again for any Twig tags when setting the custom subject. Instead, if you approach it like this - I believe it should work for you:
    'custom_subject': store_name ~ ' Bestellbestätigung ' ~ order_id
    In terms of the UTF-8 issue - I wasn't able to replicate that on my side with gmail, but I don't have a copy of Outlook to test with. Are you just seeing that with Outlook?
  • Mhm the code kind of worked, well order_id was converted, however store_name not. Although it is definitely set in the configuration. Well but it's okay for now.

    Regarding utf8 it is indeed just a problem in outlook (2013&2016) in gmail it looks fine. thus It's not super critical.
  • fc_jedfc_jed FoxyCart Team
    @fileee

    Would you mind replacing store_name with config.store_name? The store name is tucked under config and not directly just in the FC json. That could be causing the store name not showing up correctly.
  • that seems to work, thx.
Sign In or Register to comment.