HTML in language fields?

Hey guys,

In the language fields I'm able to get <em> tags working to format the text, but I can't get <a> tags working for hyperlinks. What am I doing wrong?

Example:

The autoship item you've added has been matched to your <em> existing</em> subscription schedule. If you would like the new autoship item to ship on a <em>different</em> schedule, please remove the existing subscription from the cart (top most item). <br> NOTE: Removing the existing autoship item from the cart will not cancel your existing subscription. If you wish to cancel your existing subscription, follow this link to <a href="https://secure.botanicalcraft.com/cart?cart=checkout&sub_cancel=true">cancel</a>

Comments
  • fc_adamfc_adam FoxyCart Team
    @Epotratz,

    Sorry for the inconvenience here - it does look like we're clearing out hyperlink tags. I'll check in with our team to confirm if that can be changed or for possible work arounds.
  • @fc_adam,

    Good to know I'm not losing my mind! Let me know if this can be fixed!

    Thanks.
  • EpotratzEpotratz Member
    edited December 2016
    @fc_adam,

    I just wanted to follow up on this with another issue.

    The <br> tag was working in the side-cart, but it's not working in the checkout, seen below.

    Any suggested fixes?

    image
  • fc_adamfc_adam FoxyCart Team
    @Epotratz,

    Sorry for the delay in responding! We do support HTML in some language strings - but not all of them. I'll discuss with the team about supporting it for the shipping rate label.

    You mentioned that it was working in Sidecart - are you still seeing that?
  • @fc_adam,

    Yes, it was working in the sidecart, but I actually removed the HTML markup from the shipping field so it will look consistent across all areas.

    It would be nice to get hyperlinks and html markup working for the language fields though, especially for the system messages.
  • fc_adamfc_adam FoxyCart Team
    @Epotratz,

    A quick heads up, we've just updated our default templates to support HTML in the shipping rate responses. You should see that working now on your checkout if you switch back to the custom rates with HTML in them.
  • @fc_adam,

    Thanks for the update!
Sign In or Register to comment.