Sidecart PayPal/Amazon payment options not working

Hey guys,

Product page is here: https://www.oldschoollabs.com/products/vintage-build

I've hidden PayPal/Amazon buttons with css until I figure this out.

If I disable the GA integration, the buttons work fine. When GA is enabled, the click handler doesn't properly fire and redirect to the proper checkout. How did I break this?

Thanks as always!

-Jacob
Comments
  • fc_adamfc_adam FoxyCart Team
    @jacobdubail,

    I can see what you're meaning there. I see you're using Google Tag Manager for script management on the page. Are you by chance using their native Analytics option available within Tag Manager? If so - could you try switching that off, and instead including the normal Analytics snippet as a custom tag and let me know if it starts working then?
  • Thanks @fc_adam,

    I'm hesitant to mess with GTM since we've had so many issues with reliability. I'll give this a try after hours, or actually can do it in GTM preview mode for testing. Will report back shortly.
  • @fc_adam That fixes it, but I can't go that route due to the way GTM & GA & Adwords are all integrated. Is it something that is easy to fix on your end? Thanks.
  • fc_adamfc_adam FoxyCart Team
    @jacobdubail,

    We made some updates not long ago and had to implement some work-arounds for GTM's GA integration then, but from memory it was working fine at the time. Something must have changed. We'll dig into it.
  • Thanks @fc_adam. I appreciate it!
  • fc_adamfc_adam FoxyCart Team
    @jacobdubail,

    I've had a chance to dig into this - and it relates to GTM naming the analytics trackers, when a normal integration doesn't name them (which is how our code expects it to be).

    Do these sites only have the one tracker installed for GA? You're not doing anything with having multiple different profiles tracking? If so - you can set up the GTM Universal Analytics integration to behave like a normal integration would. To do that, within GTM go to Edit Tag > More Settings > Advanced Configuration > Tracker Name, enable that option but leave the text field blank. In my testing, that makes it work as expected, while allowing you to continue using the Universal Analytics tag for GTM.
  • @fc_adam Works beautifully. Thanks for that!
Sign In or Register to comment.