Stripe API versions supported?

So, my Stripe account has told me for months that a new version of their API is available. However, I've been hesitant to click it because I don't want things to break in production. Is there any problem with proceeding with this in my account? Thanks!
Tagged:
Comments
  • summersabsummersab Member
    edited January 2018
    A little extra info - here's a breakdown of their API versions and change logs:
    https://stripe.com/docs/upgrades
  • fc_adamfc_adam FoxyCart Team
    @summersab,

    Good question. I'm not aware of any problems with any recent changes for Stripe's API that would cause conflicts with FoxyCart's integration. We have users who have create Stripe accounts recently that haven't reported any issues there, so it should be good.

    There is one caveat with that though - Stripe introduced a new requirement for accounts that pass credit card details to them directly as part of an integration. Our integration does securely pass card details to Stripe (as we do with all our gateway integrations), so an option has to be turned on for Stripe to continue working with the integration. I'm not sure if that would apply to you as an already existing account - whether it applies based on when the account was created or what version of the API it's on - but I wanted to mention just in case. We have more details on it here: https://wiki.foxycart.com/gateways/stripe#stripe_tokenization_and_unsafe_processing_errors

    I hope that helps!
  • Hmm. So, if I'm reading this right, for FoxyCart + Stripe to work, I'm supposed to enable unsafe process payment and directly connect Stripe to FoxyCart (which, in layman's terms, is similar to creating an "app password" for your Google account when you have 2FA turned on - data is still secure). Well, I have that option turned off in Stripe, I get the message of, "Good news! You’re using tokenized payment information to securely process payments on Stripe and keep your cardholder’s information safe," Stripe is set up in my FoxyCart configs, there aren't any errors in my FoxyCart logs, and I'm receiving payments with no problem. So . . . am I misunderstanding what you said? Do I need to change my integration to a) make sure everything is secure, and b) not break anything if I upgrade to the latest API version?

    I hope that made sense . . .
  • fc_adamfc_adam FoxyCart Team
    @summersab,

    You won't need to make any changes to how you have already added Stripe into Foxy - that remains the same. The only thing that would potentially have to change for your set up is enabling that "unsafe processing" option within Stripes configuration.

    Unfortunately I don't know for sure if you would have to enable that option if you upgraded your API version or not. I know that new accounts with Stripe definitely need to - but I'm not sure if as an already existing account, if you updated your API version, if you'll need to as well. To be safe, you could simply enable that option in Stripe and then upgrade the API version, and it should all be fine then.
Sign In or Register to comment.