AutoMagiCache not working on SSL secured Wordpress pages.

I am unable to cache my Wordpress template pages. Whenever I try I get the following error message:


There were difficulties caching https://grasshuggers.biz/cart/. Your template was not cached. Please review the errors below, then correct them and re-cache your template.

The URL you attempted to cache returned a status code of 403. Please confirm the URL exists, and the server is returning a successful status code, such as 200.


The URL definitely exists and when navigating to it no 403 error is returned so I am not sure what is causing the error. The only thing I can think of is the enabled SSL possibly preventing it from caching the page.

Can anyone help me?
Comments
  • fc_adamfc_adam FoxyCart Team
    @rielmedia,

    Sorry to hear you're having trouble getting your template to cache.

    The 403 response type that you're seeing there is generally a sign of a firewall of some description blocking our requests to cache the page. Do you know if you have a WAF or similar active that could be blocking our requests? If so, if you're able to disable it for your template URL's, that should allow you to get it cached. If you're not familiar, your web hosting provider may be able to provide some additional context.

    I hope that helps - let us know if you still have trouble getting it cached.
  • rielmediarielmedia Member
    @fc_adam It only appears to be happening on the cart page though. The checkout page caches with no issues.
  • fc_adamfc_adam FoxyCart Team
    @rielmedia,

    That is definitely interesting. I'm not sure why the cart would be blocked where as the checkout template isn't. Your web host will ultimately be able to provide the best assistance here though. Have you had a chance to get in touch with them about it?
Sign In or Register to comment.