payment gateway error

gl330kgl330k Member
in Bugs & Feature Requests edited May 2009
Hey gang,

We got this transaction error in our EMIS store. (ver 0.4.0)

Error: The payment gateway currently configured for this store does not appear to be fully supported by this store version.

I'm thinking this is something you'll need to look into.

Thanks
Comments
  • gl330kgl330k Member
    btw - transaction id #312124
  • brettbrett FoxyCart Team
    Hi gl330k.
    Is this a new error, or have you seen it before? Have you changed your settings (gateway, store version, etc.) recently? Were things working in the past, or are you just seeing this for the first time as you go live?
  • gl330kgl330k Member
    Brett,

    We have not seen this error before and we haven't made any payment gateway changes.

    It almost looks to me like the order went through fine. Not sure if that's the case but maybe a false-positive came back from auth.net. let me know if i need to do anything.
  • lukeluke FoxyCart Team
    ...very strange. In v040's checkout, that error is only displayed if no processor response comes back... but in this case the transaction record in the database has a saved value there... so I'm stumped.... unless it was a different transaction id.
  • gl330kgl330k Member
    huh, well for now I guess we can wait and see if this becomes a recurring thing for this store. Otherwise, we won't worry about it :)
  • jarmstrongjarmstrong Member
    edited May 2009
    I have the exact same error message in our error log as well from yesterday. Transax 312114. But, as far as I can tell, the order did not go through.

    We have not changed any of our settings recently. This is the first time we have seen this error.

    Thanks for looking into this, guys!

    julie

    P.S. (If you look in our log, ignore all those coupon errors - I was experimenting yesterday!)
  • brettbrett FoxyCart Team
    Thanks Julie. We'll take a look.
  • lukeluke FoxyCart Team
    Yeah, that order did not go through. Either the user hit cancel on their browser while it was trying to process the order or (more likely) the gateway timed out without giving us a proper error response. Hmm... we'll have to look into fixing that in a future version because if memory serves me correctly the authorize code (which started as their example code many many moons ago) checks for very specific response codes and may not handle a timeout response correctly.
  • Ok ... thanks for the update. I'll let you know if I see it again.

    julie
  • Hi,

    I started getting this error consistently with my test instance of foxycart.

    Transaction ID = 1942630
    Subdomain = devmytowndeal

    We're using the Authorize test server.
    I don't think we changed anything recently, so I'm curious where to look for the issue. Thoughts?
  • lukeluke FoxyCart Team
    Hey skymasterson. Did someone by chance adjust your payment settings to have no gateway set for a period of time? I just ran a test transaction and it seemed to work just fine for me.
  • Thanks for checking into it. No, we didn't change anything. Kind of odd, but all seems well now.
Sign In or Register to comment.