Checkout templat missing images

J. DouglasJ. Douglas Member
in Help edited January 2008
I uploaded my template to the admin, it loaded correctly, but it does not display the images.

http://www.gordons-gourmet.com/index.php?page=OnlineCustomers

Add a product to the cart, checkout and you'll see what I mean.

JH
Comments
  • brettbrett FoxyCart Team
    Hi JH.
    If you look at the paths you'll see that the checkout is trying to load
    http://www.gordons-gourmet.com/themes/images/branding_logo.gif
    where it should be
    http://www.gordons-gourmet.com/themes/Default/images/branding_logo.gif

    I think the issue is in how you have your CSS set up, using url(./images/etc...). The "AutoMagiCache" script isn't set up to handle a single dot, so I think that's the issue. It can do /, ../, http://, and nothing, but we didn't set up the ./

    We could definitely fix this, but out of curiosity is there any reason you use the ./ instead of just omitting it (which as far as I can tell would do the same thing)?
  • brettbrett FoxyCart Team
    I've gone ahead and fixed this, but I want to do a bit more testing before I push it live. I want to make sure I didn't break anything in the fixing process.
  • Ok thanks. Who knows man. I didn't code this site, just trying to retrofit a Foxycart. Just ping me when it's ready.

    BTW, on the latest version, the fancy popup that used to appear when you click "add to cart" now opens another browser tab. Should I just go back to the old version or is this another known glitch?
  • brettbrett FoxyCart Team
    From what I can tell you haven't got the necessary files in there:
    http://wiki.foxycart.com/docs:gettingstarted

    That should do the trick. If not, let me know.

    Also, heads up that your common.js seems to be empty? Not that it matters, but if it's not being used you might as well take it out.
  • lukeluke FoxyCart Team
    Another browser tab...? Do you have a target="_blank" on your add to car link?
  • brettbrett FoxyCart Team
    Sorry. I wasn't clear.

    Your links don't have the class="foxycart" on them, and I think last I looked you didn't have the foxycart_includes.js in the page either, so there's none of the necessary code to make the foxybox appear. Get the code from that wiki link I posted above.
  • Ok. I have the foxybox working now, but my custom checkout page is still missing the main image. I updated the image links in the css file to be "absolute." Not sure what else to do.
  • lukeluke FoxyCart Team
    JH, the absolute reference you're using doesn't exist:

    404 Not Found
    The requested URL /themes/images/branding_logo.gif does not exist.

    http://www.gordons-gourmet.com/themes/images/branding_logo.gif

    That's probably part of the problem.
  • brettbrett FoxyCart Team
    Yeah, there should be a /Default/ in that path somewhere. I haven't applied the patch yet that'll fix the ./ issues. I'll try to do it later tonight, which will help you avoid problems in the future.
  • brettbrett FoxyCart Team
    I just pushed that fix live. I've tested your checkout template and it caches things correctly now, but that top banner path does indeed go to a 404 error even with the correct path. You have an extra /images/ in there (so it's /images/images/).

    Once you clean that up you should be fine to recache your template and finish up.

    PS: Make sure you set your store to 0.3.1.
  • Will do. Thanks!
Sign In or Register to comment.