FoxyCart refuses to work in old versions of Safari, excluding CSSEdit

in Bugs & Feature Requests edited November 2009
Hey there,

I was annoyed to find earlier today when I went to do some styling of the FoxyCart checkout and cart templates that it refuses to load anything in older versions of webkit/Safari, which means that it won't work in CSSEdit. Any way to work around this?

Ian
Comments
  • What is the most recent version that it won't work in? (Safari 3+ seem to work fine for us.)
  • It works fine in Safari; it's specifically CSSEdit that it doesn't work (which uses webkit, and I'm assuming an older version unless FoxyCart is using non-featurebased browser detection), which is a major pain because that's the easiest place for me to tweak and actively design CSS.
  • Ahh...well, I'm not much use there. (Did notice this... http://macrabbit.com/blog/tip-cssedit-webkit-nightly/ ...not sure if that sounds helpful.)
  • lukeluke FoxyCart Team
    Hey Ian, thanks for posting. We actually haven't touched our browser detection in... well... a really long time. There's a very good chance it needs to be updated. We'll update this thread once we've done that. If you don't hear from us in a couple days, please bump the thread.
  • brettbrett FoxyCart Team
    I did actually look into this for the 050 release. The issue is that CSSEdit doesn't send version information at all. (At least, as far as I recall that was it. I might be confusing it with something else.) In any case, thanks for bringing it to our attention, like Luke said.
  • tookings: thanks for the tip; I'll see if that makes any difference.

    Luke and Brett: thanks for looking into it. I love how easy FoxyCart is to style, but it's frustrating that I can't do it as easily as I'd like. :-)
Sign In or Register to comment.