Minimum server requirements?

vossavantvossavant Member
in Help edited December 2009
Hi guys,

I couldn't find this anywhere: what are FoxyCart's minimum server requirements?

I'm about to load up a site on a host that has PHP 4.4.9 and want to make sure FoxyCart doesn't need PHP 5.

Thanks,

Ryan
Comments
  • brettbrett FoxyCart Team
    Hi Ryan.
    FoxyCart is a hosted service, so it doesn't really matter. You can use PHP4 or 5 or Python or Ruby or .NET or whatever you want for your own site. That said, most of the integrations in the wiki do require PHP5, since it has build in XML processing. I'd really try to get PHP 5.2.x, as there are a LOT of fun things that you can't easily do in PHP4.

    But for a basic integration it won't make a lick of difference.
  • Brett,

    That question seems silly in retrospect; 'twas the end of the day, so I'll give myself that excuse.

    Thanks for the answer :)
  • brettbrett FoxyCart Team
    Haha, no worries. It comes up every so often.
    That said though, I'd really strongly recommend getting a host with PHP 5.2.x+, as the more advanced you get the more you realize that you _really_ want a lot of PHP 5's stuff. Particularly the XML and JSON pieces, but also a lot more.
  • While dealing with security I also came across another reason to upgrade to PHP 5 -- the mysqli object, which lets you do things like prepared statements. For now I'm using the mysql_real_escape_string (or whatever the heck it's called), which I understand to be good enough.
Sign In or Register to comment.