The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

Taxes and SSO

nathanpitmannathanpitman Member
in Help edited February 2010
We're passing member credentials to FoxyCart from ExpressionEngine using Foxee which seems to be working fine... however...

Even though we are passing the Country value "United Kingdom" and this appears on the checkout page, the relevant tax is not added unless I force the 'auto-complete' dialog to pop-up on the Country field.

Is there a bit of JS we can pop into the checkout template to force the tax to be applied 'on load' instead?
Comments
  • brettbrett FoxyCart Team
    We're discussing this but it may be a bug. If you don't hear from us in the next few days please bump this thread.
  • lukeluke FoxyCart Team
    Hey nathanpitman. Are you using SSO (also known as single sign on or shared authentication)? I've done some testing locally with SSO and it seems to be working as expected... or are you passing in the information as a POST or GET to the cart?
  • brettbrett FoxyCart Team
    @nathanpitman Can you whisper an example so we can take a look? I was thinking that this was related to something else, but it appears not, and we can't duplicate what you're describing.
  • Luke, to clarify... yes we're using SSO. So the country value has already been pushed from ExpressionEngine to FoxyCart before we hit the checkout page. The issue seems to be more to do with an 'on load' not firing and displaying the relevant tax for the specified country...
  • lukeluke FoxyCart Team
    Hey Nathan. I had some trouble reproducing this on our test system and then I finally noticed you're on version 051. Please try upgrading to the latest version and see if that solves your problem.
  • Hi Luke, are there any issues I should be aware of in upgrading? Possible consequences in terms of our integration etc?
  • brettbrett FoxyCart Team
    http://wiki.foxycart.com/docs:upgrading
    That page should be pretty solid. I'm not sure what you'd need to do on the EE/FoxEE side of things, but I know FoxEE supports v060.

    PS: Awesome on the Solspace+FoxEE+EE user thing.
  • Hi Brett, thanks for this... if I upgrade and it breaks a ton of stuff can I easily downgrade back to 051?
  • brettbrett FoxyCart Team
    @nathanpitman: The two things with upgrading to v060 are:
    - If you're used the "fake" guest accounts by pre-populating your checkout, that could get awkward with upgrading and downgrading.
    - If you have subscriptions and let them run, I wouldn't downgrade, as each version can make changes to how subscriptions are handled.

    If you're concerned or have advanced stuff going on (which I imagine you do) I'd recommend setting up a quick test FoxyCart store, swapping the domain in EE/Foxee and testing that way. Let us know if you run into any issues of have any questions.
Sign In or Register to comment.