name lookup timed out

blacblac Member
in Help edited April 2010
One of our orders had a datafeed error: "name lookup timed out"
Our server that parses the datafeed was up and doesn't show any record of being pinged. How can we tell where the problem lies?
Comments
  • lukeluke FoxyCart Team
    Have you double checked your datafeed url? Are other transactions processing through the feed ok? What's the transaction_id and what time did it attempt to process? You can always re-feed the transaction in the admin by clicking on the plus to show the details and scrolling down a bit to click the re-feed link.
  • blacblac Member
    Yes - datafeed worked fine before and after for other transactions. I re-fed the transaction based on your instructions and it went through ok. I realize that's what I should do from now on when there is this kind of error.
    DataFeed Failed: (1290424) 2010-04-14 05:24:31
    Can you see what happened then?
  • lukeluke FoxyCart Team
    There's nothing obvious on our end so all we can go off of is the error message. It looks like the name server lookup was momentarily unable to get a value back for your domain. We'll poke around a bit more at it, but things like this unfortunately happen now and again on the net due to all the complexities of routers, switches, DNS and such.
  • brettbrett FoxyCart Team
    @blac, does your script make any calls to external systems? I'm wondering if perhaps it might have been something on your end. ie. FC -> Your Server -> failed to lookup another system and reported back that error.

    Just wondering.
  • blacblac Member
    We had that problem in the past with the consolibyte script that exports the transactions to quickbooks online timing out, so we had the script run in the background which solved the problem.
    But in this case our server logs didn't show any access to our script, so it seems like it may have been a DNS issue as @luke said.
  • brettbrett FoxyCart Team
    Huh, thanks for clearing that up. It's really nice when people (like you) have access to logs and know how to use them ;)

    Makes me all warm and fuzzy inside.
Sign In or Register to comment.