URGENT: Checkout help needed

dasharddashard Member
in Help edited September 2010
OK. I have been testing a configuration and thus have FC in test mode. Earlier today I 'upgraded' to v0.7.0 of the store. All went well. Links worked. New code plopped in fine.

Then I added items to my cart and attempted to Check Out. Everything went fine up until the actual "Confirm your Order."

The error that I get is as follows:

Error: There was an error processing your payment: The merchant login ID or password is invalid or the account is inactive. (Response Reason Code: 13)


My gateway is authorize.net. The account is active, the API login and pass are correct as verified by auth.net

I should also mention that this cart tested fine about a month ago. So to my knowledge the only difference is the store version.

One other thing: Authorize.net told me to make sure that the settings under the hood (that would be fc's settings) need to post the transaction to secure.authorize.net and NOT to test.authorize.net. They state that posting to the latter will result in an error, possibly what I'm getting.

Can you shed any light on this? This site is supposed to go live tomorrow and now this! Gack!
Comments
  • brettbrett FoxyCart Team
    Which store are you asking about? I only see one store on 070 for your account (Seriscreen) and it's not a live store (ie. it's not paid for), so it's definitely not going to work.
    20100924-cgyuhmcrcrwurtpg793278ycec.preview.jpgClick for full size

    Yeah?
  • I'm not looking for it to be live. I'm looking to "test" purchases, coupons, etc. When I click the "Confirm…" button, it errors. In the past it has always "succeeded" and forwarded the appropriate emails.

    What am I missing?
  • brettbrett FoxyCart Team
    You're not using the default test account, so unless you've created your own Auth.net test account I'm assuming that the credentials that are entered for your store are your live credentials. The live and test systems are entirely separate, so you can't use your live account to test with on their test servers. If you want to run some quick tests you could check the checkbox to set the default values.

    That'd be my hunch.
  • dasharddashard Member
    edited September 2010
    Brett -- thanks for the quick replies. My only confusion is that it worked (really… I mean it) up until today. Entered the live API codes into the FoxyCart payment settings and it worked as described above.

    Is it your definitive position that if it works with the test codes you provide (checkbox for FC test account) that it will work when it goes live? If so, I'll trust you on that. Don't want a nightmare going live with a client who's still bewildered with what a "browser" is.

    Please confirm, and thanks.
  • lukeluke FoxyCart Team
    We can't confirm it will work since only Authorize knows if the account credentials are accurate and active for a live account. If for some reasons you go live and are not able to get it to work just let us know and we'll do what we can do help you out. If Authorize is responding with a message saying the account settings are invalid then you'll have to contact them about that. As Brett mentioned, I'm pretty sure you can't use a live account on their test system.

    For what it's worth, our 070 logs show your gateway settings were modified at 2010-09-24 08:26:39 and again at 2010-09-24 11:33:17. The first modification changed from our default test account to your specific account so that probably explains why it worked before.
  • Alrightythen…guess we'll leap and see what surfaces! Thanks again for the late-night replies. Go to bed!
  • lukeluke FoxyCart Team
    We live and breathe this stuff. :)

    As they say... if you love what you do, you'll never work another day in your life.
Sign In or Register to comment.