The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

Tax not being applied when browsing from iPhone

mbowzeylombowzeylo Member
in Bugs & Feature Requests edited May 2008
Is anyone else experiencing this problem? When I add an item to my cart and proceed to the checkout using pretty much any modern browser, the tax is applied correctly to the order. However, when I perform the same transaction when browsing from my iPhone the tax is not applied. This bug is able to be duplicated 100% of the time.

To do a live test go to: servings{dot}ca/book{dot}html
You don't need to complete the order... just get to the checkout page.

It's my understanding that this is processed on FoxyCart's end? My product category for these items is setup for a tax rate of 5% and I have the "always apply taxes" field checked. So technically once FoxyCart receives the item it should run it through the appropriate product category and process the tax as per the rules setup for that specific category. At least this is my understanding. So I'm a little stumped as to how this is happening. In my mind it shouldn't really have any bearing on the web browser being used?

I would like to remedy this problem as the iPhone is set to launch in the next couple of months here in Canada.

Any help is much appreciated. Cheers.
Comments
  • brettbrett FoxyCart Team
    Well, truth be told, I was planning on doing a full on iPhone checkout customization as soon as I got one (which will hopefully be right around the 9th, or as soon as the next versions come out).

    It definitely seems odd that you're having the issue though, since the iPhone just uses Safari (kind of; it's close, and it's Webkit)... Are you experiencing this just with the iPhone or also with Safari?
  • Hey Brett... it appears to be just on the iPhone. I tested it several times using Safari 3.1.1 on an MacPro running 10.5.3 and on my MacBook, and the tax is applied correctly. I will try to test it on Safari on Windoze in the next day or two... but at this point the problem seems to be isolated to the iPhone.

    (Man, your gonna love your iPhone!)
  • PhilbyPhilby Member
    I get the same result here: no tax on the iPhone, tax calculated and applied in Safari on OS X 10.5.3.

    BTW, I second Mike: you'll find the iPhone great... I hope you'll find at least some or a little time to, ummm... work, as opposed to play around with the new toy.
  • Thanks for the additional verification Philby.

    Does anyone know of another FoxyCart powered store that is applying tax to the purchases? I should like to test at least one other store with the iPhone just to double confirm it's not my site somehow!

    Cheers
  • PhilbyPhilby Member
    A quick check on my testing store showed interesting results: looks like the iphone and safari do not display/interpret the jQuery JS exactly alike. This store is heavily modified (translations of almost everything into german "hacked" in JS), and while the tax apparently is computed and added in Safari/OS X, the shipping & handling is computed as well, but hidden (as it should be for this particular store -- another jQuery hack).
    On the iPhone, shipping & handling is computed but not hidden, and tax is neither computed nor added.
  • lukeluke FoxyCart Team
    edited June 2008
    The next version will have the latest JQuery which might help with some of these issues.

    Older versions of safari and jquery had issues with .show() and .hide() where we had to do things like .show().hide() in order to get the display to act correctly. It might be a similar issue.

    We'll see if we can play around with the SDK tools and such to test with in the meantime.
  • Interesting... not sure what fixed it but the tax seems to be calculated and added correctly on my iPhone now.
  • brettbrett FoxyCart Team
    edited November 2008
    Are you on 040 now? The 040 javascript was significantly restructured, so hopefully that did the trick. Also, 040 is using jQuery 1.2.6, which may be helping (though I'm not sure).

    Could also be an iPhone update. In any case, it's working now, so that's wonderful ;)
Sign In or Register to comment.