The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

foxycart.complete.3.js file not loading under FC v7.2

songworkssongworks Member
in Bugs & Feature Requests edited February 2012
I am developing a new site and created a new testing store. I could not get the lightbox cart to appear. I then switched this store to v7.1 and now the modal window appears.

http://mrscottmusicman.com.s60002.gridserver.com/charlenepooter/store/time-to-move/
Comments
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    When you switch versions, make sure that you update your FoxyCart embed code as each version has different embed code.
  • fc_adamfc_adam FoxyCart Team
    As sparkweb said, it sounds like you needed to update your embedded FoxyCart includes. You can get them from the Sample Code section of the administration.
  • OK. Thanks for the clarification. I should've actually read the Upgrade Notes. :)
  • UGH! I'm not following the instructions here, guys. I'm trying to use 7.2. I took the sample code presented to me after I added a store... it includes foxycart.complete.3.js, but the modal does NOT work. It directs me to the cart as a whole page. I check the sample code section and it all appears to be really old code. Why am I given code that returns a 404?
  • fc_adamfc_adam FoxyCart Team
    Hi rexolio,

    If you're on version 0.7.2, you won't be using a foxycart.complete.3.js file. Make sure your includes are what is displayed in the Sample Code section of the FoxyCart administration for your store.

    If you still have problems, if you could link us to your site, we can take a look.
  • lukeluke FoxyCart Team
    edited March 2012
    @rexolio: we just fixed a bug yesterday (we're still QA'ing it now) that was showing the wrong includes in the admin under sample code right after you create an 072 store from an existing 071 or 070 store. If you log out of the admin and log back in again, you should see the correct values which include foxycart.colorbox.js

    We're very sorry for the confusion here. This bug has taken us quite a while to track down and reproduce, but we think we finally have it nailed. The fix impacts all versions of the admin, so we have to test it thoroughly and make sure it doesn't have any unintended consequences. Thank you for your patience with us.
  • No worries, @luke... just glad it wasn't me! :) Appreciate the stellar support and product!
  • SamiSami FoxyCart Team
    The fix has been tested and is live now.

    Thanks for the patience.
  • Hi guys... sorry to bother you again. The code still isn't popping up in the colorbox for me; it's instead opening a new page. I'm going to whisper the link to you, but I'd appreciate any insight you can provide.
  • fc_adamfc_adam FoxyCart Team
    @rexolio,

    You'll need to remove the jQuery that you're also including on your page, it looks like this:
    <script type="text/javascript" src="/wp-content/themes/helpinghands/js/jquery-1.3.2.min.js"></script>
    

    A version of jQuery is already included with FoxyCart, and including another one afterwards generally has bad side effects like you're seeing.
  • You guys rock... I knew not to do that, but totally missed it!
Sign In or Register to comment.