Going live - issues

triphoptriphop Member
in Help edited July 2012
Hi all,
We have made our store live in the Foxycart admin however we are still getting the 'This store is currently configured on a test gateway...' message when we click through from the cart.
I have updated the cart template cache from Wordpress which was fine, however i get a timeout error in the WP admin when I try to update the Checkout template cache. Could this be what is causing the problem and preventing the store from going live?
Everything worked fine on the development server and the checkout template cache updated fine, so i don't know why it should be having trouble now.

I'll whisper the URL to a member of the Foxycart team if they respond.

Thanks
Tagged:
Comments
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    You need to go to your Payment section in the FoxyCart admin and switch your payment gateway from TESTING to LIVE and that ought to do it.
  • fc_adamfc_adam FoxyCart Team
    @triphop,

    As the message notes (and as @sparkweb pointed out) your store is currently set to a test gateway. You'll need to have both an active subscription and live gateways configured for a store for an alert not to appear on the checkout.

    Is your caching still timing out as well? If you could whisper us which store it's for, we can take a closer look.
  • fc_adamfc_adam FoxyCart Team
    @triphop, {in response to whisper}

    I was able to successfully cache your template from the administration for your checkout template, although it did take a fair while to cache - I'm assuming the timeout you're seeing is from within the FoxyShop administration?

    Perhaps @sparkweb might be able to weigh in if there is a specific time that FoxyShop will allow for requests on the API.

    There are quite a few scripts included on the checkout - perhaps try trimming off some of those that you're not actually using on your checkout and see if it loads quicker for you.
  • fc_adam,

    Hi Adam, I know and agree there's a lot of 'baggage' on the template but whenever i tried trimming it down (Wordpress), Foxycart wouldn't cache it, the only way it would cache was leaving it as is - I spent about 2 days trying to make it slicker.

    Thanks for that though, much appreciated.
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    You can extend the timeout by putting this in your wp-config.php file:
    define('FOXYSHOP_CURL_CONNECTTIMEOUT', 30);
    define('FOXYSHOP_CURL_TIMEOUT', 30);
    

    More info here: http://www.foxy-shop.com/documentation/advanced-settings/
Sign In or Register to comment.