Coupon is applied in cart, and displays the discount, but doesn't actually discount

cbootcboot Member
in Help edited August 2012
This is a strange problem reported to me by my client. We have a special product that you can order one of two ways, all at once, or via a payment plan. We enacted the payment plan be creating a subscription with a calculated end date based on the date of purchase. We have coupons that we want to work for both the payment plan AND the full purchase price. I'll simplify the prices for my explanation. For example, if they use a 10% off coupon, it will take $60 off the $600 full purchase price OR $6 off each of the 10 payments of $60. This kind of coupon works perfectly so far, as desired. However, we also have coupons that are not discount by a percentage. Rather, these additional discounts are "discount by an amount based on the price in this category". So let's say they have a $30 off coupon. The coupon details I set up for that coupon looks like this: 1-3|599-30. In other words, if they are purchasing the payment plan (which obviously costs less than 599) it deducts 3 dollars every payment (after 10 payments, this is $30 total). However, if they purchase the full item, costing $600, it should deduct the $30 all at once. And, in fact, it does. But not on every computer. On several computers, everything looks completely fine at checkout, and on others it shows the discount name but just deducts $0 from the price. It is not browser specific, as we have tested it across multiple browsers. Any ideas as to why the discount is not being applied on some computers while it is on others? I can whisper you the details of our account if you'd like to take a closer look. I also have several screenshots that might shed some light if you need them. Thank you!
Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    edited August 2012
    @cboot,

    Yeah, if you could whisper us those details, and also put up the screenshots somewhere we can see, that would also help a lot. If you don't have somewhere to host the images, you can email them to helpdesk (a t) foxycart (d o t) com
  • fc_adamfc_adam FoxyCart Team
    @cboot,

    Looking at the screenshot you whispered, the screenshot of the cart with the coupon that doesn't work doesn't have a category assigned to it. The one that does work has a category applied. As the coupon is only valid for certain categories you'll need to make sure that all of your add to carts are given a category. I believe it's the top right add to cart that's the issue.
  • @fc_adam

    Thank you so much! I feel really stupid. There was an error in the code that was supposed to put the category name in that link. We were confused because I was using one link while the client was using the other. You have saved me a great deal of time and frustration!
  • fc_adamfc_adam FoxyCart Team
    @cboot,

    No worries at all - it's the little things that catch us out the most often :)
Sign In or Register to comment.