Urgent: site launched, now using remote domain, error message 'site is not currently set up'

kanjigirlkanjigirl Member
in Help edited December 2012
My client paid for an SSL cert and got this message from Foxycart on 10/31/12:

----
We're all finished setting up your custom SSL certificate. It looks like you still need to set up your CNAME record; everything else is set up and ready to go.

Instructions on setting up your CNAME record are available here: http://wiki.foxycart.com/docs:remotedomain:setup#site_dns_setup

After you have set up your DNS record and verified that it's working properly, you will need to update your FoxyCart store's "use remote domain" setting and update your site's add-to-cart links and any links to scripts included from the FoxyCart servers.
----

I just launched the site, moved it from my server to www.kontour.com. We're still on the test payment gateway, but I switched to 'store remote domain' and entered 'secure.kontour.com' as instructed by the client. She set up the CNAME record on 10/31 as well.

I just changed all the script links throughout the site from kontour.foxycart.com to secure.kontour.com. Now on every page I get the 'Kontour is not currently set up' warning popup. You can see it here:

http://www.kontour.com/about.html

What am I doing wrong? Before I changed to secure.kontour.com and changed the script links, I was able to run a test order and view all pages with no problem at all.

Tagged:
Comments
  • Also, forgot to mention I recached my cart/checkout/receipt template, cleared the Foxycart image cache, and cleared my browser cache.

    When I tried to add something to the cart just now I saw:

    "We're sorry, the store you requested could not be found or it has not yet been configured with a cart template and default product category. Please check back later."
  • fc_adamfc_adam FoxyCart Team
    @kanjigirl,

    The includes you have on your page aren't correct - you'll need to grab the latest includes from the sample code section of the stores FoxyCart administration.
  • Partially fixed - I changed the links on all pages to match the sample code. All pages are now loading without the error, but when I try to put something into the cart I now get a page with:

    "This webpage is not available
    The server at secure.kontour.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.
    Here are some suggestions:
    Reload this webpage later."

    Here is a buy page with the corrected links:

    http://www.kontour.com/typefaces_axia_styles.html
  • fc_adamfc_adam FoxyCart Team
    @kanjigirl,

    I've been speaking with our sysadmin, and from what we can tell the CNAME record isn't there anymore. Could you get your client to verify that the CNAME is still set up correctly as per the instructions on the wiki here: http://wiki.foxycart.com/static/redirect/custom_domain
  • Thanks, I'll get the client to check this ASAP.
  • Ah - the client reports that BlueHost says the CNAME record is set up properly, but when I try to add an item to the cart, first I get the usual screen about the untrusted (new) SSL, once, and then I get this:

    "404 Not Found

    The resource requested could not be found on this server!
    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!"

    This is for this URL, a link from the page listed above with corrected links:

    https://secure.kontour.com/cart?name=Axia Bold (1%20Style)%20Open%20Type%20Desktop&price=60&category=Fonts&code=Axbold3&quantity_max=1&fcsid=e9v1u7gvn6debfscfgfa3ofb43
  • fredfred FoxyCart Team
    Hi there,

    I just checked and the DNS record is still not correct. You have:
    secure.kontour.com.	14146	IN	CNAME	secure.kontour.com.dns.foxycart.com.
    

    It needs to be:
    secure.kontour.com.	14146	IN	CNAME	secure-kontour-com.dns.foxycart.com.
    

    Replace the dashes in your DNS name on the right-hand side and it will be correct.

    Given your site launch, I have created a temporary extra record so that the DNS record you made will start working.

    Once you can visit https://secure.kontour.com/cart?cart=view without getting an SSL warning, you can go ahead and enable "use remote store domain." Be sure to update your FoxyCart script includes on all of your pages when you do so, see the "example code" section of the Admin dashboard after you upgrade.

    After your dust settles, please fix your DNS record to use dashes instead of dots.
  • Cart appears to be working now as the client's made the changes you recommended - thanks for your help!
  • fc_adamfc_adam FoxyCart Team
    Awesome - glad to hear it!
Sign In or Register to comment.