fc_error_session

undzundz Member
in Help edited December 2012
Where can we access the fc_error_session infos.
On our site, since we upgraded to 1.0, the link to get back to the site and the LET US NO link are not working.
Comments
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    I'm not quite sure I understand. You can go to https://admin.foxycart.com/admin.php?ThisAction=ErrorLog to see the FoxyCart error logs. I see these fine in my 1.0 store. Is this what you aren't seeing?
  • No,
    When a customer is getting to the checkout section without anything in is cart,
    there is a custom error message with a link back to the site.
    THOSE LINKS do not work properly since we upgraded to 1.0
  • fc_adamfc_adam FoxyCart Team
    @undz,

    Oops! You're right!

    I'll ticket that on our end and we'll take a look and get that fixed up as soon as possible.

    For now, you can edit the language string in the 'language' section of the FoxyCart Administration for your store. Simply switch out ^^store_url^^ for your actual store URL.
  • @fc_adam

    ok we will switch the store url in the language for now,
    tks
  • @fc_adam

    The ^^store_url^^ for those error message are not in the language section.
    i made a search in the entire page and the only ^^store_url^^ are for one other thing.
  • fc_adamfc_adam FoxyCart Team
    @undz,

    If you look under 'checkout' on the language page of your stores Admin, you should see ^^store_url^^ inside of the text field for 'error session'.
  • @fc_adam

    I know,
    but my error message (there is 2 version)

    1) only says that my cart is empty with a link back)
    2) a complete infos of why and 2 links)

    Both text that i see ARE NOT in my checkout language infos.

    Seems like i still have the old error session from older version with the command of the new 1.0

    Possible?
  • lukeluke FoxyCart Team
    Hey @undz. It looks like the ^^store_url^^ place holder is not working correctly in 1.0. We just submitted a fix for testing and we'll roll it out to release as soon as it's ready.

    As Adam said, you should be able to adjust that text directly using your admin's language string. It's under "Checkout" and then "error session." If you're still having trouble, can you please provide us with a screenshot so we can help you further and better understand what trouble you're running into? Also, it would be helpful to know which store you're working with.
  • @luke

    here is what is going on.

    1) my language section is updated to 1.0 and the error_session message
    is NOT the same i can see in our checkout

    2) we have a custom SSL (secure.undz.org) . Maybe the custom SSL do not upgrade automatically
    like a foxycart checkout would?

    3) It is clear that we still have the old error massages on a empty checkout and that the one
    we should be able to modify in language is the new one
  • fc_adamfc_adam FoxyCart Team
    @undz,

    Looking at your store's checkout (with an empty cart) and looking at your stores language setting, I see those two language strings matching. Could you screenshot what you're seeing on your checkout? (secure.undz.org/checkout)
  • There is 2 messages.

    the first is pretty simple

    Your shopping cart is empty.
    Undz.org



    the other one is longer and seems to match the message in the language section
  • lukeluke FoxyCart Team
    Hello undz. Can you please provide some screenshots so we can better understand your question? What, exactly, is the problem you're seeing and what are you trying to accomplish?

    When I look at your checkout, I see this which matches your template:
    http://screencast.com/t/uHQi7XHzJj

    When I view an empty cart, I see this, which also matches your template:
    http://screencast.com/t/zzAeNKGT3MN

    Are you wanting to change the "Your shopping cart is empty." text? If so, you can do that within your language settings under cart via the "empty" language key.

    I hope that helps.
Sign In or Register to comment.