The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

The $0 shipping bug is fixed! [AGAIN]

lukeluke FoxyCart Team
in Important News edited October 2008
Hey all... just wanted to post an update about a bug that has plagued us since the very beginning and may now finally be put to rest. We've had a few scattered reports over the years about users checking out without paying for shipping. A shipping method would actually be selected, but the shipping cost would come through as $0.

We just committed a fix that should finally solve this pesky problem. We try to avoid updating existing store versions whenever possible, but in this case we patched it back to version 0.3.0. Please let us know if you find anything out of the ordinary.

For the curious, the $0 shipping bug was caused when someone updated their address, selected a shipping method and then changed the address by selecting the "use a different address" or something similar and then checked out while the AJAX results were still loading. The old values hadn't been cleared out yet so the validation code thought everything was fine but no shipping method was selected a second time to update the price.
Comments
  • brettbrett FoxyCart Team
    edited October 2008
    This fix will actually be pushed live tomorrow. Sometimes (like now) fixing one bug creates another. We'll report back once it's pushed live again.
  • brettbrett FoxyCart Team
    This fix has been pushed live. If this issue comes up for anybody in the future please let us know.
  • lukeluke FoxyCart Team
    When we rolled out this fix last week, we also rolled them back to the 0.3.x versioned stores which was a bad idea. Due to a variation in error validation, we ended up making things worse.

    It should be working correctly now. Please let us know if you find any other problems.

    More info is available in this thread.
  • Yup. We hit the issue too with a few customers. I upgraded to 4.0 and haven't had a problem since.

    (Upgrade from 3.2 to 4.0 went very smooth, BTW. I really like the model you guys are using for upgrade--letting it be customer-controlled even tho it's hosted sw.)
Sign In or Register to comment.