Error when trying to cache self-hosted checkout template (RESOLVED)

mattjacobymattjacoby Member
in Help edited March 2013
*Original Post Removed, Update on this issue below*
Tagged:
Comments
  • Nevermind, needed https on those file paths. :) Works now. Thanks.
  • I'm sorry, this is the worst thread I've ever started!

    While the cache was successful, my stylesheets still don't load. Firebug says they were aborted. Now, it probably has something to do with the fact that they aren't really under an SSL, but I used HTTPS to get the cache to work correctly. Do stylesheets imported in the cart require an SSL on the domain?

    Thanks.
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    @mattjacoby - you definitely don't want to put https if you don't really have an https in place. The way that the automagic cacher works is that you put in your http:// url and then when you click the cache button it downloads your stylesheet writes them inline on the checkout page so that it's served securely.

    Read http://wiki.foxycart.com/v/1.0/templates#important_notes for some important notes about this. The biggest thing that I usually run into is rel="stylesheet" not being first.
  • @sparkweb yeah I understand how it works, it's just really picky. The guidelines you sent helped. I found that the import in my stylesheet wasn't liked (child theme in WordPress). I just put the absolute path in there and it fixed it. My rel="stylesheet" tags were first already. :)

    Thanks!
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    oh yeah, it doesn't like relative paths either. That can be really tricky on the child theme stylesheets. I feel your pain!
  • Shared pain is the best kind in a forum right? :) Thanks for your help!
Sign In or Register to comment.