The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

Data Feed 404

jlivingstonjlivingston Member
in Help edited May 2013
Hi Guys,

Last night, I moved one of my client's sites to a new server. In an unrelated task today, I ran some test orders on their site, and their datafeed worked fine. However, later today a real order came through, and the datafeed returned an error: "DataFeed Failed: (68999919) 2013-05-08 17:28:37 No data returned for http://domain.com/data_feed_script.php [404]" (I obviously changed the URL). I ran a test on the datafeed after I saw this, and the test worked fine. The only thing I can think of is that maybe this has something to do with DNS propagation. But why would it return a 404? The datafeed script is currently active on both servers. Also, I checked the DNS propagation last night here http://www.whatsmydns.net/ and it indicated that the propagation was complete world-wide, for what it's worth. Any ideas what might be happening?

I'm going to whisper the domain to a couple of you. Let me know if you have any thoughts.

Thanks,

Joey
Comments
  • fc_adamfc_adam FoxyCart Team
    @jlivingston,

    We'll take a look and see if anything pops up.

    When you say you run a test though, what exactly does that entail? Are you running a test transaction through the store, or are you triggering it some other way?
  • Hi Adam. I'm firing a PHP file on the same server, that submits some test XML through CURL.
  • fc_adamfc_adam FoxyCart Team
    @jlivingston,

    I'm seeing two successful transactions fed to your datafeed since that one - looks like this has resolved itself. Could you try refeeding that one that failed and see if it feeds correctly?
  • Hi Adam. It's strange, because it's still returning that error that makes it look like a 404, but of course how could that possibly be so? Could you look further into this for me?
  • fc_adamfc_adam FoxyCart Team
    @jlivingston,

    So just to confirm - any new orders coming in are working just fine - it's just this previous order that is causing issues, and whenever you try to refeed that order to the datafeed, it's returning that 404 error. Is that right?
  • Oops. Sorry, I obviously missed this post a few days ago.

    Yes, that's correct.
  • fc_adamfc_adam FoxyCart Team
    @jlivingston,

    So it's obviously something unique to that particular order. Do you have access to your servers error logs to see if anything is appearing in there? Or the PHP error logs for your datafeed script too?
Sign In or Register to comment.