update version of colorbox on the cdn for jq1.9 compatibility?

mwahahamwahaha Member
in Help edited May 2013
In the CDN file for foxycart.colorbox.js i'm currently seeing what you guys are calling:

// ColorBox v1.3.19.3 - jQuery lightbox plugin

which is about a year and a half old (Dec 2011). I'm getting console errors with Jquery 1.9, because the old code used ".live" somewhere.

Colorbox changelog shows lots of 2013 updates:

https://github.com/jackmoore/colorbox#changelog

Version CB1.3.21 brings JQ1.9 compatibility. I could host it CB locally but it would be simpler and slightly faster if you guys could just update the script on the CDN. Could you bump up the script to CB version 1.4.7, the last version before Jack dropped support for IE6 with 1.4.8? That way there's zero loss in browser support, and it clears the path to jquery 2.0.

Thanks!
Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    edited May 2013
    @mwahaha,

    We've updated to jQuery 1.9 and colorbox version 1.3.23 libraries in our latest version of FoxyCart - version 1.1. We don't upgrade older versions of FoxyCart as it would create issues for existing users of that version. 1.3.23 was the newest version at the time we performed the upgrade earlier this year for the files. We try to update the libraries in each version of FoxyCart we release to be as up to date as possible.

    You can manually update the files for your version of FoxyCart if you want - but one thing to note, with jQuery 1.9 there are a number of functions that are removed after being depreciated for a time - so there will probably be incompatibilities in the FoxyCart JS pre FoxyCart version 1.1.
Sign In or Register to comment.