Checkout is asking for a password even though default is set to guest

mreeemreee Member
in Help edited July 2013
When I fill out my information and try to checkout I get an error at the top which tells me to enter a password.

If I click the checkout as guest radio button (which is already selected) then I can get through fine.

I am pretty sure that checked default to guest in the settings but I can't find it in the admin area.

Thanks for the help!

URL for my checkout: [link]
Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    @mreee,

    Could you whisper us the email you're using to test that you're seeing this error with? You can whisper to me by selecting the 'Whisper' checkbox and entering my forum username in the box that appears. That way we can test with exactly what you're seeing, as I just put through a couple tests and wasn't able to get it to trigger the request for password.
  • fc_adamfc_adam FoxyCart Team
    @mreee,

    Thanks for whispering that information. I just tried a checkout using your email, and wasn't able to reproduce what you're describing either.

    When you enter your email, does it display the following text?
    "That email address doesn't belong to any previously saved accounts. Please select "create an account" below if you'd like to save your details for your next visit."
  • mreeemreee Member
    I get that right after I put in my email.

    However, it gives me the please enter a password error after I fill everything out and try to complete the order. The page refreshes and I get that password error.
  • fc_adamfc_adam FoxyCart Team
    @mreee,

    So the page actually refreshes completely? Could you copy and paste into here the error that you're seeing at the top of the page please?
  • mreeemreee Member
    This is the message - Error: Please enter a password.

    After I click 'complete your purchase' the checkout.php page refreshes and I get the error as a list-item at the top of the page.
  • fc_adamfc_adam FoxyCart Team
    @mreee,

    That's really weird. I'm going to ask one of our developers to grab some of the logs from the transactions to see why it's thinking server-side that your store isn't allowing anonymous transactions. We'll be in touch as soon as possible.
  • mreeemreee Member
    Once I get the error I can click checkout as guest (even though it is already selected) and checkout fine.

    I have had a few friends try it and they are getting the same error.
  • lukeluke FoxyCart Team
    I was able to reproduce the error on our test environment and there appears to be something broken involving guest checkouts. We'll get back to you as soon as we have more information.
  • mreeemreee Member
    Is my store the only one having the problem?

    How long do you think it will take to fix?
  • lukeluke FoxyCart Team
    I've spent hours trying to track this bug down and was extremely confused as many of my fellow team members were not seeing the same issue I was. I finally realized it only happened in Chrome when I used an autofill suggestion it made. More on the bug in Chrome can be found here:

    http://productforums.google.com/forum/#!topic/chrome/WNBd8p6q7YQ

    Basically they rolled out a bug in their autocomplete that deselects the radio buttons. That's a big problem and definitely breaks the checkout.

    The suggest they have in there is to add autocomplete=off to all radio buttons. That's something you could do now on your store by replacing the default twig template with a customized version available here: http://wiki.foxycart.com/v/1.1/templates#using_twig_with_foxycart

    The radio buttons in the checkout template would need to have autocomplete=off add to them. We'll be looking into this further to see if it makes sense for us to make this change for everyone in response to a bug introduced by the Chrome browser.

    Also, if you upgrade to the latest version of Chrome, it should be fixed.
  • mreeemreee Member
    Thanks for you help!

    I used jQuery to add auto complete off to the the radio buttons.

  • lukeluke FoxyCart Team
    FYI, we just pushed up a change which includes autocomplete="off" into all versions of the checkout for radio buttons.
  • Still experiencing autocomplete fields staying on and being messed up as well - i.e. my zip appears as my name etc.. Also experienced somer weirdness where I submit and get a message that it was submitted incorrectly - pressing checkout again does it. Here's a post of interest - my issues are all with Chrome. http://stackoverflow.com/questions/12374442/chrome-browser-ignoring-autocomplete-off
  • Adding this to my template has successfully disabled Chrome's autofill.
    $(document).ready(function() {
    if (navigator.userAgent.toLowerCase().indexOf('chrome') >= 0) {
        setTimeout(function () {
            $('form, input').attr('autocomplete', 'off');
        }, 1);
      }
    });
    
  • fc_adamfc_adam FoxyCart Team
    @happycloud,

    What version are you running for your store?
  • @fc_adam - latest - I think 1.1
  • fc_adamfc_adam FoxyCart Team
    @happycloud,

    Very weird. We rolled some code out a couple weeks ago that should prevent the chrome autofill functionality from incorrectly completing the form like you're experiencing, and looking at your checkout I am seeing those values we added in your form.

    I'm also unable to replicate Chrome not respecting an autocomplete value of off though. Very weird.
  • @fc_adam - I think it's only some chrome versions - from that SO post above that seems to be the case. I am using 28.0.1500.71 beta. My code snippet seems to have taken care of it so I'll leave it there.
  • fc_adamfc_adam FoxyCart Team
    @happycloud,

    I'm using 28.0.1500.71 m, weird. Glad your fix worked for you.
Sign In or Register to comment.