Foxy Forum Status

We're no longer responding to questions via our forum, but we will keep it up for historical reasons. If you can't find the answer you're looking for, please visit our knowledge base or contact us. If there's enough interest in the future, we may bring the forum back.

DataFeed Failed: (163586441) No data returned for ... [403]

fueljonyfueljony Member
in Bugs & Feature Requests edited November 2013
I'm running into a strange issue with my datafeed, everything has been running smoothly until today, I noticed that one of my transaction's datafeed wasn't processed so I tried to re-feed it, however I wasn't able to get it to work, I kept getting a "No data returned" on the error log, after a lot of debugging on my script I tried to re-feed another transaction and everything worked (with the original script), but when I tried to re-feed this one (163586441) it said again that "No data returned", I even tried to 'die("error");' at the very top of my script and it would still say "No data returned". I hope you guys can take a look at it.

Thanks for the help.
Tagged:
Comments
  • sparkwebsparkweb Member, Integration Developer, FoxyShop, Order Desk
    @fueljony,

    The usual suspects here are:
    -Caching
    -Error Reporting Got Turned Off

    Can you try making a totally fresh file at just says die("error"); so that you can be sure it isn't caching?
  • fredfred FoxyCart Team
    Hi @fueljony,

    I see that your script is returning a 403 ("access denied") response code. Is that something from your datafeed script or possibly something from your web server / .htaccess settings? If you're running on a shared host, they oftentimes do extra filtering as well that returns a 403 response.
Sign In or Register to comment.