Google Chrome form autofill

PecanPecan Member
in General edited March 2014
A user emailed me not so long ago to say that when he was completing the checkout page, Chrome auto-populated all of his delivery info (must be a feature of Chrome. not sure) and when he clicked to place the order he got an error saying that the form fields were empty.

He then had to go back and pretend to type something into each field to satisfy the form validation police.

I just thought I'd mention it. I know there is a new version coming up soon, perhaps this has already been fixed. If not, it might be worth looking into so that Chrome users aren't getting upset when filling out Foxy checkout pages.

Thanks
Comments
  • fc_adamfc_adam FoxyCart Team
    @Pecan,

    Interesting. We haven't had that kind of issue reported before - it's definitely a weird one. I've tested with Chrome autofillers and haven't bumped into that myself. Autofill plugins is something we were just discussing amongst the team this last week, and something we'll be testing as we continue to finish of the next version.

    Thanks for bringing it up - we'll keep an eye out for this kind of thing as we test.
  • PecanPecan Member
    @fc_adam,

    No problem. It sounds like something which is only going to affect the minority but I thought it was worth mentioning.

    By the way, I can't wait for version 2.0. It looks fantastic. :)
  • fc_adamfc_adam FoxyCart Team
    @Pecan,

    And we can't wait to get it out into the world!
  • @fc_adam,

    We're seeing a similar issue to Pecan's, but with autofill of credit card fields on our new 2.0 checkout page. I've only tested it with Chrome, so can't say if it effects all browsers. Specifically, when Chrome autofills the credit card form, the first 3 fields appear to populate appropriately. CSC doesn't populate of course, so you have to type that in manually, which is fine. But then validation fails upon order submission and an error message is returned indicating that the year was not entered. It's strange because both the month and year are select lists, and while the month seems to validate just fine, the validation fails to recognize the autofilled year input. If you then manually pick the correct year from the drop-down list and resubmit the order, it goes through okay.

    Lots of folks use autofill for cc info and we'd prefer not to make them enter the year twice. Is there a fix for this? See before and after screenshot below...

    image

  • THIS, we have the same error for more than a few users. Auto completing is just not working. Could you maybe look into it.
  • fc_adamfc_adam FoxyCart Team
    We have a fix pending for this issue to better detect changes caused by an auto-fill plugin, which is currently within QA.

    @fileee, are your users reporting this for the credit card fields as well, or something else?
  • fc_adamfc_adam FoxyCart Team
    @Pecan, @Leafcutter, @fileee,

    We've just pushed out some code today that should improve the autofill issues you were describing in this thread. Thanks for your patience while we looked into this issue.
  • fileeefileee Member
    Sry to not have responded, i did not see that. Thanks for looking into it. The main issue is with the adress and email. As far as i can see it, it works now, but i need to get back to the people reporting it
Sign In or Register to comment.