Svg images are not displaying and fonts not displaying correctly

davidzupecdavidzupec Member
in Help edited May 2014
Hello, I had cached my checkout template and for some reason my svg social icons in my header and footer aren't showing up. Also my heading and footer fonts don't want to display the correct font.
Comments
  • fc_adamfc_adam FoxyCart Team
    @davidzupec,

    Could you let us know what store this is for? Are you using webfonts? There are some considerations for using webfonts with our caching functionality - you can see those in the "notes on fonts" here: http://wiki.foxycart.com/static/redirect/automagicache
  • Hi Adam, I'm using fontsquirel to embed the fonts. The navigation menu font should be museo slab as well as the footer H1 tags and my social icons that that should show up in the header and footer are svgs images. The store is for Captains Neck & Co. Thank You!
  • fc_adamfc_adam FoxyCart Team
    @davidzupec,

    You need to actually base64 encode the fonts and include that block within the checkout template - rather than just linking to the individual font files. You can do that by selecting "Expert" on the FontSquirrel page and checking "base64 encode" under "CSS". Try that and see if that fixes the issue for you.
  • Thank you fc_adam that worked for the fonts! Would you know by any chance why my social svg icons don't display? They are illustrator images that are linked out as well.
  • Sorry, I figured it out. I forgot to cache the icons : )
  • fc_adamfc_adam FoxyCart Team
    @davidzupec,

    Awesome - glad you got it sorted.
Sign In or Register to comment.