The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

Custom template 302 caching error.

captain_yarcaptain_yar Member
in Help edited February 2015
Hey guys, I've been using FC for a long while now and love it. In this instance, I am using the wonderful WordPress plugin, Foxy Shop.

The issue is that I am constantly getting a 302 error for my custom cart template, but I am not getting any errors on the custom receipt and checkout templates. I do understand that this 302 error can have a number of reasons as to why it's being thrown. I have checked and re-checked the domains to make sure they are all the same. I have changed the CDN (mainly just Google) paths to be http and https. I left the trailing slash on the URL and removed it. I have even went as far as to remove everything from the template itself and just have the word, "poop". Still a 302 error. Makes no sense. I am at about wits end here.

WordPress 4.1
Foxyshop 4.5.3
Foxycart 2.0

Any assistance from you guys would be very much welcomed and appreciated.
  • fc_adamfc_adam FoxyCart Team

    Could you let us know what store this is for? If you'd prefer to keep it private, you can whisper it using the whisper option when replying.
  • @fc_adam, I've whispered the info to you. Thanks.
  • fc_adamfc_adam FoxyCart Team

    Thanks for whispering those details. The issue you're running into is the page requires a logged in administrator to view. As FoxyCart isn't a logged in user, it's getting redirected to your login page - which is why you're seeing the 302 HTTP response in the error. If you make the template page public, you should be able to cache then.
  • Ah, are correct. Of course it is the simple things in the end....I should have known that since that is how the site is set up.

    Thank you for the help.
Sign In or Register to comment.