Unknown Gateway Error

I can't seem to figure out why I am getting these unknown gateway errors when setting up with Securenet..

Any ideas on what to check?

Thanks in advance!
Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    @slimeygecko,

    Could you let us know your store? We'll take a look at the errors and see if we can tell why it's returning that error for you.
  • fc_adamfc_adam FoxyCart Team
    @slimeygecko {in response to whisper},

    Thanks for whispering that - we're reaching out to the SecureNet support to see what may be the issue here.
  • Thank you!
  • Any news or progress?
  • brettbrett FoxyCart Team
    @slimeygecko, we've started a conversation with them, but haven't got to the root cause. It looks like it was a temporary error, but we'd like to figure out why it happened.
  • Let me know when you figure it out. I'm curious to know the cause.

    Does that mean it should work now? I'll test it again to see if I can process payments.

    Thanks again for your help.
  • brettbrett FoxyCart Team
    @slimeygecko, we think it should be working fine now. I'm sorry for not clarifying that, but the logs that I saw made me think you'd made successful attempts afterwards (so I thought you knew it should be working again).

    If it's not working… let us know. And I'll ask for an update from them again right now. Sorry for the trouble. We've got a lot of users with them and we haven't seen this before.
  • Thanks for getting back to me Brett. I just tested it again and get the same error. I believe I am using the correct ID and Key (the public key that has this description: 'Retrieve the Public Key to be used along with SecureNet ID for API Integrations with Tokenization').
  • fc_adamfc_adam FoxyCart Team
    @slimeygecko,

    We've just heard back from their support again today - it looks as though you're using an incorrect "key" value. They mentioned you'll need to login to the SecureNet administration, navigate to "Settings" and then to "Obtain Secure Key". Give that a try and let us know how you go.
  • I really thought I had tried both keys (public key and secure key) initially when setting this all up. Thank you for getting back to me, I just confirmed that it all works properly.

    It does seem odd that the error I got back was 'Unknown Gateway Error' instead of 'Incorrect Key'. Maybe this is something to change down the road.

    Thanks again
  • fc_adamfc_adam FoxyCart Team
    @slimeygecko,

    Awesome - I'm glad that got it working. And we agree about the error, we're following up with their support team about getting that one fixed for the future.
Sign In or Register to comment.