SSO Sessions

solankillsolankill Member
I am having trouble with the Session data being read on mySSO endpoint. When a user logins in to the website, and adds a product to the cart, it will add the product and when checkout is clicked, the SSO endpoint does not see the user as logged in. If i access the page directly however, it does see that the user is logged in. The problem only occurs if the page is accessed through the foxycart checkout button. Any thoughts on why this is? I can post some code here if necessary.
Comments
  • brettbrett FoxyCart Team
    Hi @solankill
    When you say "it does see that the user is logged in", you mean a page on your end?

    It sounds like perhaps your SSO endpoint is a different domain, so when the user requests that endpoint page, their session cookies (for your site) aren't being read by your serverside scripts? That's the only thing that'd make sense. More info would help us better understand what's going on.
  • Hey Brett, I think we are in contact via email right now but I will explain here so maybe others can chime in as well.

    My domain is afroattire.com

    The sso endpoint is on afroattire.com/ssoredirect.php

    So when on the cart page the user clicks on checkout it goes to ssoredirect.php to authenticate the user on my end and then continue on to make the link to the checkout page.

    Here is the issue, the user logs in to my site. When he adds a product and clicks checkout for some reason the user is not recognized as logged in so no customer id is passed.

    If, however I go directly to ssoredirect.php from any page on my website, it will read the the user is logged in.

    Do you think there is something in my session setting script that prevents it from being set due to being redirected from another domain?

    I am not sure because as mentioned the user is shown as logged in if I access the page directly but it does not work when it is redirected to by clicking the checkout link from the cart.

    I can send you the code for starting the session, maybe you might see if that is the issue?
Sign In or Register to comment.