The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

Avoiding resubmission warning when going from checkout back to full page cart?

When I go to the checkout and then use my browser's back button I am presented with a form resubmission warning before being able to go back to the cart (presumably). When I confirm the going back, my browser (i.e. Google Chromium / Chrome) takes me back to the page I called the cart from instead of the cart itself.

So the way I get to the checkout is...

Site product page -> cart -> checkout

But on going back it is the following (after going through the resubmission warning)...

Checkout -> Site product page

Is there a way to make the above be seamless in terms of going from one page to the other such that it would be...

Site product page -> cart -> checkout
OR
Checkout -> cart -> Site product page

Without a resubmission warning which is going to confuse the heck out of some potential customers (who may not be very internet savvy) and may cause them to abandon the sale.

Carlos
Comments
  • fc_adamfc_adam FoxyCart Team
    @carlos123,

    I'm unable to replicate that on my test store. Could you link me to the product page for the starting point to replicate that please?
  • Hmm...it does not work this way under Firefox. Firefox behaves beautifully in that regard and goes back and forth between the site product page, cart, and checkout pages without a hitch.

    There seems to be a bug in Chrome that is causing this glitch.

    I cannot easily test under IE (at least not at this moment) so I have no idea how that browser would behave.

    Just wondering if you know of an effective way around this under Chrome at least?

    There are some techniques that may work but I don't want to go mucking around and changing things too much if I can help it :).

    This used to be a problem with most all browsers but apparently Firefox fixed this issue.

    Carlos
  • carlos123carlos123 Member
    edited June 2015
    Here is an interesting technique that someone has been using for years without a problem.


    //If there's something in the POST, move it to the session and then redirect right back to where we are
    if ($_POST) {
    $_SESSION['POST']=$_POST;
    redirect($_SERVER["REQUEST_URI"]);
    }

    //If there's something in the SESSION POST, move it back to the POST and clear the SESSION POST
    if ($_SESSION['POST']) {
    $_POST=$_SESSION['POST'];
    unset($_SESSION['POST']);
    }


    You can see that in the comments at http://stackoverflow.com/questions/660329/prevent-back-button-from-showing-post-confirmation-alert/26348520#26348520

    It's a PHP solution. I offer it as something that might prove useful since the server code you run FoxyCart on behind the scenes (if I am not mistaken) is PHP.

    Maybe I can figure out how to do the same thing in custom Javascript or something. Don't know.

    Will wait for any further response from you Adam before I go mucking around trying various things.

    Google's Chrome has a BIG market share these days so I do want to fix this if I can as it is problematic.

    Carlos
  • fc_adamfc_adam FoxyCart Team
    @carlos123,

    Chrome is what I'm using when I'm testing your store, and I'm not getting that message when pressing the back button from the checkout to return to the full page cart.

    Did you try testing without any extensions in Chrome to see if they may be affecting something?
  • My bad Adam. Sorry.

    I turned off all extensions and sure enough...going back and forth between the site product page, the cart, and the checkout works well.

    I apologize for much ado about nothing.

    I will have to make sure I turn off all extensions in the future before I report or ask about a possible problem.

    Carlos
  • I was experiencing a similar problem on my site a long time ago. I primarily use Chrome and have installed a ton of extensions. It was indeed causing all the problems. Switched to Firefox :)
Sign In or Register to comment.