Default Country Bug

Hi guys,

I had a customer notice that their store (in Australia) is now defaulting the country to the United States.

I've double-checked their admin settings (which haven't changed) and re-saved the country as Australia and timezone as Canberra, yet still the country drop-down defaults to US.

This store is super-old (0.7.0) and I can see on a newer store for a different client (also in Australia) that's running 2.0 gets the country correct.

Any ideas?
Comments
  • fc_jedfc_jed FoxyCart Team
    @Phil

    Hi, sorry to hear you're running into a bit of trouble. Could you send me the store domain in question so that we could investigate?
  • brettbrett FoxyCart Team
    Hi @Phil.
    That's odd. Is it happening across the board? We use a geo IP database that gets updated monthly, so unless there're some template customizations going on changing things (or maybe you're doing a checkout prepopulation on that field?), that definitely shouldn't be happening.
  • PhilPhil Member
    edited July 2015
    Hey @brett.

    It only seems to be happening to that 0.7.0 store in particular. And you're right, it seems like the geo IP lookup just no longer fires when the checkout page is rendered.

    I've got conflicting reports from the client that this may have started after your recent downtime, but can't confirm that for sure at the moment.
  • tachyontachyon Member
    edited July 2015
    I can confirm that this is happening to my client's store too (v0.7.1) - Also an Australian store.

    Since pre-populating the country isn't supported on 0.7.1, does anyone know of any workarounds?
  • fc_jedfc_jed FoxyCart Team
    edited July 2015
    @Phil and @tachyon

    Yes, I see it now. Unfortunately, pre-2.0 bugs aren't a priority in terms of providing code fixes, but we'll see if there could be a workaround for this.

    I'm a bit unfamiliar with how 0.7.0 and 0.7.1 looks, but I've forwarded your concerns to the team. Someone will get back to you when there is more information regarding this. Thank you both for your patience.

    EDIT: Would your clients consider upgrading to the latest version so that these issues would be resolved?
  • fc_jedfc_jed FoxyCart Team
    @Phil and @tachyon

    This issue has now been resolved. Sorry for the inconvenience earlier and thanks for bringing this issue to our attention. If you have additional concerns, please don't hesitate to get in touch with us again.
  • I had a customer email this morning with the same issue. She was seeing international shipping rates in the cart rather than the domestic rates. I told her to select the US as her country and that fixed the issue. However, seeing the international rates first made her want to abandon her purchase.
    Is there a way to set the default shipping rates to the US until a customer selected international, or is this always determined by IP address?
    We are using version 1.1
  • fc_adamfc_adam FoxyCart Team
    @nordicgal,

    With the issue fixed, the customer should see the rates correctly as expected now. Sorry for the inconvenience for you and your customer!

    The shipping rates should always be determined by the country selected for the shipping address.
  • Awesome. Thanks so much @fc_adam !
Sign In or Register to comment.