Foxyshop Product Pages 404

yoayoa Member
Hello,


I recently updated wordpress and the foxyshop plugin to the latest versions and i initially thought all was well but all the product pages now lead to a 404 page.

http://www.foxy-shop.com/faqs/my-product-pages-just-show-up-as-a-404/

Following the instructions from the above page i have a flushed my permalink settings via the foxyshop tools section and in the actual permalink settings section of wordpress as well by clicking save.

Wordpress tells me that the "permalink structure has been updated" but still all my product pages show a 404 page.


Ive tried disabling all my plugins but it seems its NOT a plugin conflict. Ive also tried changing the permission of the htaccess file in the wordpress dir to 666 and then changing the permalink setting and then reverting back to 644 but that didnt do it either.



Initially i thought this was some theme issue as i changed themes right after upgrading but toggling back to my old theme or even just vanilla twenty10/11 still gives 404 on all the product pages. Keep in mind the rest of the site works fine. Its just the foxyshop product pages that are displaying the 404, not any other pages. For example the foxyshop product category pages work fine.



When i began updating wordpress and foxyshop it was with the intention of upgrading to foxycart 2.0. I have since upgraded to foxycart 2.0 thinking i would get a clean slate but that didnt help at all. All the product pages still show 404.



Below is the contents of my htaccess file. I have flushed the permalink settings like 20 times and its just not restoring the product pages.

Can someone point me in the right direction? Im at a loss right now..



**************************************

# BEGIN WordPress

RewriteEngine On
RewriteBase /shop/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /shop/index.php [L]


# END WordPress

**************************************








Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    @yoa,

    @sparkweb would be the person to help you here - David built FoxyShop, and frequents the forums so I'm sure he'll be in touch here soon.
  • Hey Adam!

    David rescued me via email so i came back to post the fix.


    What restored the product pages was using an advance setting via the wordpress config file ( wp-config.php ). You can read about it here.

    http://www.foxy-shop.com/documentation/advanced-settings/


    Basically i added this line to the wordpress config file.

    define('FOXYSHOP_PRODUCTS_SLUG','something-else');


    The "something-else" being what ever slug you want to use. In my case my new theme housed 4 custom post types that bogarted the "products" slug that foxyshop uses.

    I either had to set a new slug... something besides products, or get rid of the plugin that housed the 4 custom post types and set the slug back to products using the wordpress config file.



    Anyway .. im good to go. I just got my first look at vanilla foxycart 2.0!

    It looks awesome! Im really excited to start using it. The combination of Foxyshop and Foxycart has been really good to us for the last few years so we are looking forward to another long run on the foxycart 2.0 platform.


    A big thanks to David and everyone at Foxycart!



    Best,
    Yoa






  • fc_adamfc_adam FoxyCart Team
    @yoa,

    Awesome! Thanks for posting your solution here too.
Sign In or Register to comment.