The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

WP Affiliate not tracking purchases

We installed the WP affiliate tracking software into a Wordpress site following the 4 steps here:

https://wiki.foxycart.com/integration/wp_affiliate

The software records the click through, but it doesn't record a sale or commission.

Is there any known issues/conflicts with this plugin on Foxycart 2.0?
Comments
  • fc_jedfc_jed FoxyCart Team
    @flinx777

    The best place to put that in your receipt template is just after the closing </div> tag and before the closing </body> tag. Also, remove the old placeholder tags that were meant for pre-2.0 stores. I'm not that familiar with the WP affiliate tracking software, so tagging @fc_adam to provide insight.
  • fc_adamfc_adam FoxyCart Team
    @flinx777,

    I've just updated that wiki page to work for version 2.0. Take a look at the updated information for steps 2 and 3 and that should hopefully get you on track.
  • @fc_adam @fc_jed

    Thanks for the updates on 2.0. Will review and update accordingly.
  • @fc_adam we updated the code per the docs and the client ran another test. The results were the same, the clicks are shown in the report but not the final transaction.

    I'll whisper the store information to you.
  • fc_adamfc_adam FoxyCart Team
    @flinx777,

    Ah - sorry. I just realised what the issue is. This image is being served insecurely as http://. As the receipt for 2.0 is served securely by default, browsers are blocking that image from loading. Try updating the URL to be https:// for the image, it looks like you have an SSL certificate on the domain so that should work fine.

    I'll update the documentation to note that.
  • @fc_adam, we're still running into the same problem even with this last update. The clicks are registering, but the final sale is not. Any ideas?
  • fc_adamfc_adam FoxyCart Team
    @flinx777,

    Looking at your store's configuration, the image is still set to be served as http://. It needs to be set to https://.
  • @fc_adam per the instructions, if the client does not have a SSL cert on their site, then we have to use http:// and then change the configuration setting on the receipt to http://, correct? Did I read that correctly?
  • fc_adamfc_adam FoxyCart Team
    edited September 2015
    @flinx777,

    Oh sorry - I hadn't noticed that you had taken that route. For what it's worth - the website does have an SSL certificate installed for their domain. The approach you've taken would also be fine though.

    I'm not really sure what's stopping this from working at this point unfortunately. I did a quick test of the code on my own test store, and it's outputting the values correctly - for example it looked like this (altered to hide the domain and secret string):
    <img border="0" src="http://www.WEBSITE.com/wp-content/plugins/wp-affiliate-platform/api/post_by_ip.php?secret=00XXXX000XX00&sale_amt=45&txn_id=8684936889" width="1" height="1" >
    When you load the receipt after completing a purchase with your browsers inspection tools open - do you see that image load in the network requests?
Sign In or Register to comment.