The Foxy forums are on the move!

We're in the process of moving our forums over to a new system, and so these forums are now read-only.
If you have a question about your store in the meantime, please don't hesitate to reach out to us via email.

SSO problem

sankesisankesi Member
I have installed "foxycart-6.x-1.1" module on my Drupal website (version 6.2).

Everything works fine so far, but there is a SSO problem presenting when I follow below steps:

1. I have enabled “single sign on” in the FoxyCart store settings under the "advanced" menu.
2. customer password hash type is “MD5, unsalted”
3. when I login on my website.
4. put something in the cart.
5. click on “Proceed to Checkout”
6. there is only an error message on the browser, which is
“SimpleXMLElement Object ( [store_version] => 2.0 [result] => ERROR [messages] => SimpleXMLElement Object ( [context] => 2001 [message] => Customer Not Found (customer_email:xxxxxxxxxxxxx@xxxxxxx.com, customer_id:) ) ) ”
7. then I click “go back” on the web browser (return to the shopping cart)
8. click on “Proceed to Checkout” again
9. this time everything is ok, I got the checkout page.

I tested several user accounts, only when I first time click on “Proceed to Checkout”, I got that error message.

Is there anyone can help me fix this issue?

Thank you.
Tagged:
Comments
  • fc_adamfc_adam FoxyCart Team
    @sankesi,

    The error message you're seeing there I believe is coming from your SSO endpoint. It's trying to find the customer via the API, but is reporting that it's unable to find them. Generally on an error like that - where there is a user logged in on your website but they don't exist on the store, the SSO endpoint would then use the API to create them on the store before forwarding the customer on to the checkout authenticated.

    It sounds like that's either happening the first time, but it's failing to correctly forward you, or it's happening on the second attempt.

    I'll reach out to the developer who worked on the Drupal extension and hopefully he might be able to shed some light on what's happening here.
  • fc_adamfc_adam FoxyCart Team
    @sankesi,

    Actually - I just noticed your store version is 2.0 - but the version of the extension you're using I believe is for older versions of FoxyCart. Perhaps try using the more recent version of the module from here: https://www.drupal.org/project/foxycart
  • Thank you @fc_adam
    Yes, I am using "foxycart-6.x-1.1" module on my Drupal website (version 6.2). Since my Drupal version is 6, so this extension is already the latest version on the list. https://www.drupal.org/node/735676/release

    Is there any possibility that you could update "foxycart-6.x" to make it support store version 2.0?

    Thank you.
  • fc_adamfc_adam FoxyCart Team
    @sankesi,

    Unfortunately we don't directly support the Drupal modules, these have been developed by members of our development community. I'll reach out to that developer I mentioned previously to see if they have any suggestions
  • Thank you for your help @fc_adam
  • jasonjason Member, Integration Developer, FoxyPal
    Hi @sankesi,

    I'm the creator of the Drupal module. There's no plan update the 6.x version of the module to support FoxyCart 2.0. I really haven't had time to support the 7.x version much either. I certainly welcome patches if you're able to contribute there. In either case, you'll want to look into upgrading your Drupal site very soon. Drupal 6 support was dropped back in February and you'll leave yourself open to security vulnerabilities if you don't upgrade.

    https://www.drupal.org/drupal-6-eol
Sign In or Register to comment.